Перейти к содержимому

Cache module status failed hp proliant что это

  • автор:

HP StoreOnce 4500 Backup — Cache module status — Failed

Добрый день. Имеется HP StoreOnce 4500 Backup на которые еженедельно бэкапятся данные.

HP StoreOnce 4500 Backup

Тип
HP StoreOnce 4500 Backup
Имя
HPCZ2511083J
Серийный номер
CZ2511083J
Версия программного обеспечения
3.12.1-1513.3

Сегодня обнаружили следующие ошибки:

В виду этого на сервер не могу скопировать бэкапы т.к. Nas постояно отключает сетевые папки.

component:superCapacitor, status:FAILED, location:IOCacheModule in storageController S/N:PCUUVC18S7X05I in PCI Slot 1 in server HPCZ2511083J, Message: The supercap has failed., Diagnostic message: Replace the supercap., uuid:50014380266AB5F0_IOC_1,50014380266AB5F0_BAT_1, eventName:SUPER_CAPACITOR_FAILED, eventId:001C0002, level:ALERT, category:SERVER, overallStatus:DEGRADED , name: ch_34303936-3538-5A43-3235-31313038334A , engine name: hpcz2511083j

component:IOCacheModule, status:FAILED, location:IOCacheModule in storageController S/N:PCUUVC18S7X05I in PCI Slot 1 in server HPCZ2511083J, Message: Write caching using the IO cache module has been temporarily disabled. This will cause degraded performance., Diagnostic message: Check the supercap status and if applicable the partner controller’s supercap status. If the supercap statuses are good, contact HP technical support for further assistance., uuid:50014380266AB5F0_IOC_1, eventName:IO_CACHE_MODULE_CACHE_DISABLED, eventId:00080003, level:ALERT, category:SERVER, overallStatus:DEGRADED , name: ch_34303936-3538-5A43-3235-31313038334A , engine name: hpcz2511083j

Сообщение ошибки в ILO:

POST Error: 1705-Slot X Drive Array — Please replace Cache Module Super-Cap. Caching will be enabled once Super-Cap has been replaced and charged.

Я так поняж нужно поменять батарейку модуля кэша

Скажите пожалуйста, в чем причина не исправности?

Можно ли парт номер или ссылку необходимой запчасти для замены.

Linux: Работа с RAID контроллером от HP

HP-Smart-Array-P410-RAID-Controller-Card-462919-001-wSFF-8087-mini_SAS-Battery-291402637154-4

Небольшая инструкцию по мониторингу и настройке Raid массива на Raid контроллерах HP под CentOS 6.7.

При наличии необходимых навыков эта инструкция подойдет под любой другой дистрибутив Linux.

1) Для начала убедимся, что у нас есть HP контроллер:

Смотрим в разрезе устройств на шине:
# lspci | grep -i RAID 06:00.0 RAID bus controller: Hewlett-Packard Company Smart Array G6 controllers (rev 01)
Устройств при загрузке:
# dmesg | grep -i RAID dracut: rd_NO_DM: removing DM RAID activation dracut: rd_NO_MD: removing MD RAID activation hpsa 0000:06:00.0: RAID device c4b3t0l0 added. scsi 4:3:0:0: RAID HP P410 3.66 PQ: 0 ANSI: 5
Или проверяем наличие символьного устройства hpilo.

Стоит уточнить, что на нескольких серверах, несмотря на наличие контроллера, символьного устройства не было.

#cat /proc/devices | grep hp 250 hpilo

1а) Более длинными способами, можно получить похожую картину:

Через smartctl:
# smartctl -i /dev/sda smartctl 5.43 2012-06-30 r3573 [x86_64-linux-2.6.32-573.18.1.el6.x86_64] (local build) Copyright (C) 2002-12 by Bruce Allen, http://smartmontools.sourceforge.net Vendor: HP Product: LOGICAL VOLUME Revision: 3.66 User Capacity: 1,499,830,990,848 bytes [1.49 TB] Logical block size: 512 bytes Logical Unit id: 0x600508b1001851395358343048380c00 Serial number: PACCR9SX4205 Device type: disk Local Time is: Thu Mar 3 14:27:52 2016 MSK Device does not support SMART
Через lshw:
# lshw -c disk *-disk:0 description: SCSI Disk product: LOGICAL VOLUME vendor: HP physical id: 0.0.0 bus info: scsi@4:0.0.0 logical name: /dev/sda version: 3.66 serial: PACCR9SX4205 size: 1396GiB (1499GB) capabilities: 15000rpm partitioned partitioned:dos configuration: ansiversion=5 logicalsectorsize=512 sectorsize=512 signature=0004650e *-disk:1 description: SCSI Disk product: LOGICAL VOLUME vendor: HP physical id: 0.0.1 bus info: scsi@4:0.0.1 logical name: /dev/sdb version: 3.66 serial: PACCR9SX4205 size: 1117GiB (1200GB) capabilities: 15000rpm partitioned partitioned:dos configuration: ansiversion=5 logicalsectorsize=512 sectorsize=512 signature=b294fbcd

2) Устанавливаем утилиту hpacucli.

Подключаем репозитарий HP:

Версию и разрядность системы необходимо подставить самостоятельно или написать общий шаблон.

cat spp.repo name=Service Pack for ProLiant baseurl=http://downloads.linux.hpe.com/repo/spp/rhel/6Server/x86_64/current/ enabled=1 gpgcheck=0 gpgkey=file:///etc/pki/rpm-gpg/GPG-KEY-ServicePackforProLiant
# yum install hpasmcli
Как вариант ставим RPM пакет HP, который соответствует вашей системе:
rpm -ivh http://downloads.linux.hpe.com/repo/spp/rhel/6Server/x86_64/current/hpacucli-9.40-12.0.x86_64.rpm warning: hpacucli-9.40-12.0.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 2689b887: NOKEY Preparing. ########################################### [100%] 1:hpacucli ########################################### [100%] DOWNGRADE NOTE: To downgrade this application to any version prior to 9.10.x.x, the current RPM must be manually uninstalled using the "rpm -e" command before any prior versions can be installed. LOCKING NOTE: The locking mechanism starting with versions 9.10.X.X, are not compatible with prior versions of the applications. Therefore, mixing older and newer versions of the various applications (ACU, HPACUCLI, HPACUSCRIPTING) is not recommended.

3) Начало работа с hpacucli.

Проверяем статус контроллера:

Команда для проверки hpacucli controller all show status

Нормальное состояние контроллера должно отображаться так:
# hpacucli controller all show status Smart Array P410 in Slot 1 Controller Status: OK Cache Status: OK
С чем я сталкивался:
Отсутствие «Cache Status» говорит об отсутствии батареи у кеша.

В этом состоянии:
— по неподтвержденным данным замедленной работой контроллера, по сравнению с присутствием батареи;
— невозможностью расширения массива на лету, путем добавления дисков и т.п.

Error: This operation is not supported with the current configuration. Use the "show" command on devices to show additional details about the configuration. Reason: Transformation size zero
Батарея есть, но подлежит замене

Примерно тоже самое, что выше, но также есть риск потери данных кеша при внезапном отключении питания.
Ошибка выглядит так:

Smart Array P410 in Slot 1 Controller Status: OK Cache Status: Temporarily Disabled Battery/Capacitor Status: Failed (Replace Batteries/Capacitors)

2016-03-02 11-00-48

2016-03-02 11-04-24

2016-03-02 11-04-30

Пора заменить микрокод контроллера!

Ошибка намекает на несовместимость утилиты hpacucli с установленным микрокодом в контроллере. Вариант или подобрать утилиту или обновиться.

Smart Array P410 in Slot 1 CACHE STATUS PROBLEM DETECTED: The controller is disabled because the cache module is not attached. Please re-attach the cache module to re-enable the controller.

Процедура обновления достаточно простая, но как обычно существуют стандартные риски при обновлении любых рейд контроллеров и это тема для отдельной статьи.

Заинтересованным смотреть с Firmware CD Supplemental Update Smart Array P212, P410, P410i, P411, P712m, and P812. Обновление прошло на лету, изменения применяются после перезагрузки.

Это же обновление лечит появление ошибок вида:

hpsa 0000:06:00.0: CDB 2a000d407ca800000800000000000000 : hardware error
Перед обновлением собираем диагностическую информацию:

Данные будут доступны в «/tmp/diag_log.txt»

# hpssacli ctrl slot=1 diag file=/tmp/diag_log.txt Generating diagnostic report. done
А также текущую конфигурацию контроллера:
# hpssacli ctrl all show config Smart Array P410 in Slot 1 (sn: PACCR9SX4205 ) Port Name: 1I Port Name: 2I DL18xG6BP at Port 1I, Box 1, OK array A (SAS, Unused Space: 965488 MB) logicaldrive 1 (1.4 TB, RAID 5, Transforming, 49.22% complete) physicaldrive 1I:1:1 (port 1I:box 1:bay 1, SAS, 300 GB, OK) physicaldrive 1I:1:2 (port 1I:box 1:bay 2, SAS, 300 GB, OK) physicaldrive 1I:1:3 (port 1I:box 1:bay 3, SAS, 300 GB, OK) physicaldrive 1I:1:4 (port 1I:box 1:bay 4, SAS, 300 GB, OK) physicaldrive 1I:1:5 (port 1I:box 1:bay 5, SAS, 300 GB, OK) physicaldrive 1I:1:6 (port 1I:box 1:bay 6, SAS, 300 GB, OK) physicaldrive 1I:1:7 (port 1I:box 1:bay 7, SAS, 300 GB, OK) physicaldrive 1I:1:8 (port 1I:box 1:bay 8, SAS, 300 GB, OK) physicaldrive 1I:1:9 (port 1I:box 1:bay 9, SAS, 300 GB, OK) array B (SAS, Unused Space: 0 MB) logicaldrive 2 (1.1 TB, RAID 5, OK) physicaldrive 1I:1:10 (port 1I:box 1:bay 10, SAS, 600 GB, OK) physicaldrive 1I:1:11 (port 1I:box 1:bay 11, SAS, 600 GB, OK) physicaldrive 1I:1:12 (port 1I:box 1:bay 12, SAS, 600 GB, OK) Enclosure SEP (Vendor ID HP, Model DL18xG6BP) 248 (WWID: 50001C1071540013, Port: 1I, Box: 1) Expander 250 (WWID: 50001C1071540000, Port: 1I, Box: 1) SEP (Vendor ID PMCSIERA, Model SRC 8x6G) 249 (WWID: 50014380042FABEF)

Проверяем ранее собранную информацию. В моей диагностике видно, что запущено расширение массива (хотя оно было уже после накатки микрокода), что определенно вводит ограничение на обновление.

4) Настройка RAID с hpacucli.

Просмотр статусов логических дисков
#hpssacli controller slot=1 logicaldrive all show status logicaldrive 1 (1.4 TB, 5): OK logicaldrive 2 (1.6 TB, 5): OK

Если логический диск в «работе» статус это покажет.

Результат добавления дисков в массив:

#hpssacli ctrl slot=1 ld 1 add drives=1I:1:7,1I:1:8,,1I:1:9 #hpssacli controller slot=1 logicaldrive all show status logicaldrive 1 (1.4 TB, 5): Transforming, 49.13% complete logicaldrive 2 (1.1 TB, 5): OK
Просмотр статусов физических дисков

Один из дисков в режиме «скоро умрет».

#hpssacli controller slot=1 physicaldrive all show status physicaldrive 1I:1:1 (port 1I:box 1:bay 1, 300 GB): OK physicaldrive 1I:1:2 (port 1I:box 1:bay 2, 300 GB): OK physicaldrive 1I:1:3 (port 1I:box 1:bay 3, 300 GB): OK physicaldrive 1I:1:4 (port 1I:box 1:bay 4, 300 GB): OK physicaldrive 1I:1:5 (port 1I:box 1:bay 5, 300 GB): OK physicaldrive 1I:1:6 (port 1I:box 1:bay 6, 300 GB): OK physicaldrive 1I:1:9 (port 1I:box 1:bay 9, 600 GB): OK physicaldrive 1I:1:10 (port 1I:box 1:bay 10, 600 GB): Predictive Failure physicaldrive 1I:1:11 (port 1I:box 1:bay 11, 600 GB): OK physicaldrive 1I:1:12 (port 1I:box 1:bay 12, 600 GB): OK physicaldrive 1I:1:7 (port 1I:box 1:bay 7, 300 GB): OK physicaldrive 1I:1:8 (port 1I:box 1:bay 8, 300 GB): OK

Можем получить более детальную информацию:

#hpacucli ctrl all show config detail | more
Создание RAID массива
# Создание логического диска с RAID 0 включающего один физический диск hpacucli ctrl slot=1 create type=ld drives=1I:1:10 raid=0 # Создание логического диска с RAID 1 с двух физических дисков hpacucli ctrl slot=1 create type=ld drives=1I:1:10,1I:1:11 size=300 raid=1 # Создание логического диска с RAID 5 с тремя физическими дисками hpacucli ctrl slot=1 create type=ld drives=1I:1:10,1I:1:11,1I:1:12raid=5
Добавление дополнительного физического диска к логическому
hpacucli ctrl slot=1 ld 1 add drives=1I:1:10
Добавить запасной диск:
hpacucli ctrl slot=0 array all add spares=1I:1:10
Увеличение размера логического диска до указанного в size, после добавление нового физического
hpacucli ctrl slot=1 ld 1 modify size=500 forced

В моем случае ругнется и даст подсказку — нельзя делать диск меньше чес он сейчас.

Error: "size=500" is not a valid option for logicaldrive 1 Available options are: Max: 2288560 (Units in MB) Min: 1430350 (Units in MB) MaxMBR: Max. for MBR Partition Table (2097152 MB = 2 TB)

Свободное место можно взять из детального вывода «hpacucli ctrl all show config detail».
У меня после добавления свободно 0,9Tb

Array: A Interface Type: SAS Unused Space: 965488 MB Status: OK Array Type: Data
Работа с внутренним кешем
#Изменить пропорции кеширования: hpssacli ctrl slot=1 modify cacheratio=100/0 # Выключить/включить кэш hpacucli ctrl slot=1 modify dwc=disable hpacucli ctrl slot=1 modify dwc=enable

Категория: Администрирование

HP proliant cache module failure

In our windows server environment, we often get the alert for HP servers that storage cache module has failed. What exactly is the function of cache module?

asked Feb 22, 2020 at 11:19
Soumendra Patra Soumendra Patra
23 1 1 silver badge 4 4 bronze badges

1 Answer 1

Unfortunately, you are neither mentioning a specific server model nor a specific controller, thus I’m assuming Smart Arrays here. HP/HPE Smart Array RAID controllers provide a battery-backed cache to e.g. temporarily store data before transferring them to disks. The cache is DRAM, thus it’s a lot faster than typical disk drives, and this speeds up e.g. write operations.

Let’s go one step back: Once a data write to the cache is completed, the cache must be able to protect the data in case of a power loss before the data has been transferred to the drives. This happens using a battery, and the battery is normally what fails after some time which leads to alerts or failure reports, because you might be on risk when using a non-battery-backed cache. If this does not apply for you, you should provide a specific failure message here.

The HP document Smart Array technology: advantages of battery-backed cache describes the details of the cache in detail.

answered Feb 22, 2020 at 12:33
356 1 1 silver badge 7 7 bronze badges

You must log in to answer this question.

  • hp-proliant
  • hp-smart-array
    Featured on Meta
Related
Hot Network Questions

Subscribe to RSS

Question feed

To subscribe to this RSS feed, copy and paste this URL into your RSS reader.

Site design / logo © 2024 Stack Exchange Inc; user contributions licensed under CC BY-SA . rev 2024.1.26.3951

Сравнение двух серверов HP ProLiant DL380 серии G5 и G6

Пасека Старчевских

Уже почти год прошёл с тех пор, как компания Intel представила свою новую архитектуру Nehalem на серверном рынке, но в то же время процессоры предыдущего поколения на базе ядра Harpertown не исчезли с рынка, и соответственно возникает вопрос — какой архитектуре отдать предпочтение при выборе сервера? Intel поддерживает такую интересную ценовую политику, что за стоимость процессоров Xeon нового поколения можно приобрести неплохой Xeon предыдущего поколения, причем с более высокой частотой.

Сегодня мы рассмотрим два сервера DL380 от компании Hewlett Packard. Один — DL380 G5 , рассчитанный на установку процессоров Xeon 54xx предыдущего поколения, другой — DL380 G6 — на самые современные Xeon серии 55xx на архитектуре Nehalem. Сравнив их по скорости и конструкции, мы сможем дать ответ на главные вопросы — стоит ли переплачивать за новые процессоры и какой прирост скорости вы получите при замене старых серверов на новые.

HP ProLiant DL380 — это универсальные серверы для малых компаний и предприятий. Собранные в стоечных 2U корпусах, — они позволяют устанавливать до 4 плат расширения c интерфейсами PCI Express / PCI-X для решения различных задач. Используя до 8 современных SAS винчестера формата 2.5 дюйма, вы можете настроить различные конфигурации RAID массивов под ваши нужды. Топовые модели оснащаются 2 процессорами Intel Xeon с индексом производительности 50 или выше ( Xeon X545 0 или X5550 ). Компания Hewlett Packard позиционирует серию DL380 для использования с любыми приложениями — от традиционных почтовых серверов крупных организаций, web-хостинга и серверов баз данных, для использования в кластерных системах с повышенными требованиями к доступности и производительности. Например, для расчетов физических процессов, моделирования и разработки контента. Проигрывая 1U-моделям в плотности вычислений на 1 юнит, DL380 наверстывает упущенное по количеству плат расширения и жестких дисков.

Естественно, смена архитектуры процессоров — отличный повод для производителя обновить свой сервер полностью. И модификации G5 и G6 отличаются не только материнскими платами, как у других производителей серверов. Для DL380G6 компания Hewlett Packard использовала новое шасси, которое до этого использовалось в AMD серверах. Начнём как раз с различий конструкции.

HP ProLiant DL380 G5

Сервер, собранный в 2U шасси получился очень тяжёлым – около 22 Кг с жёсткими дисками. Корпус достаточно жёсткий, и даже если приподнять его за один угол – не будет даже намёка на изгиб, как в некоторых дешёвых серверах. Ну, в общем-то, в этом никто и не сомневался.

Сервер HP Proliant DL380 G5

Посмотрим на лицевую панель сервера. Восемь жёстких дисков формата 2.5 дюйма установлены вертикально, в ряд, с правой стороны. Стандартные лотки для SAS винчестеров HP с функцией горячей замены имеют специальные наклейки с указанием модификации и ёмкости винчестера для лёгкой замены в случае выхода из строя. Над каждым из винчестеров указан его порядковый номер, но белый цвет на сером фоне – не лучшее решение, особенно для мрачных дата-центров. Вертикальное расположение дисков – не очень удобно, если вам надо быстро достать диск и посмотреть его маркировку непосредственно на винчестере. Незанятые HDD дисками корзины закрыты заглушками.

Сервер HP Proliant DL380 G5

Слева от винчестеров, в центральной части лицевой панели располагается удобная индикация состояния основных компонентов сервера. Одного взгляда на неё достаточно, чтобы понять, работают ли блоки питания, вентиляторы, модули памяти и платы расширения, а так же нет ли перегрева. Под ней расположены дополнительные индикаторы активности сетевых интерфейсов и кнопки Power и UID (световая индикация). Кнопки Reset в сервере нет, видимо HP считает, что их машины не зависают, но на самом деле – это не так, и отсутствие Reset-а – недостаток!

Сервер HP Proliant DL380 G5 - вид спереди

Левая сторона лицевой панели выглядит пустой. Под большой вентиляционной решёткой располагаются оптический привод slim форм-фактора, два порта USB 2.0 и один VGA выход. Вообще, серверы HP DL380 имеют по две интегрированных видеокарты, с двумя VGA выходами для удобного подключения KVM консолей как с лицевой стороны, так и с обратной. Для удобного извлечения сервера из стойки, слева и справа предусмотрены складные ручки. В принципе, к лицевой панели сервера есть одна серьёзная причина придраться – плохо читаемые надписи. В остальном же, всё соответствует корпоративным требованиям.

Сервер HP Proliant DL380 G5 - вид сбоку

Отвод воздуха, в основном, осуществляется через боковые вентиляционные решётки. Причина этого достаточно проста – при установки всех возможных плат расширения, вентиляторам уже будет трудно продуть корпус от лицевой панели до задней. Правда, насколько это решение оправдано при установке машины в серверный шкаф, мы не можем сказать.

Сервер HP Proliant DL380 G5 - блок питания

В зависимости от модификации, вы можете заказать серверы HP ProLiant DL380 G5 с одним или двумя блоками питания мощностью по 800 Вт каждый, обеспечивающими достаточную избыточность в соответствии с требованиями доступности сервера. Оба блока питания имеют горячую замену, активную компенсацию PFC и соответствуют стандартам CE Mark. С обратной стороны присутствуют порты PS/2 для клавиатуры и мышки, два порта USB 2.0, VGA порт, два сетевых RJ45 и один RJ45 для встроенной системы мониторинга iLO2.

Сервер HP Proliant DL380 G5 - вид сзади

HP ProLiant DL380 G5 имеет возможность установки двух низкопрофильных и трёх полнопрофильных плат расширения. Первые две устанавливаются вертикально напрямую в разъёмы материнской платы, остальные – через райзер. Материнские платы серверов ProLiant DL380 G5 не имеют встроенного аппаратного RAID-контроллера, так что если вы выберете этот контроллер в качестве опции (например, HP Smart Array P400) – он будет занимать один из слотов. Хотя, и оставшихся – более чем достаточно для большинства ситуаций. Но давайте посмотрим, как организовано внутреннее пространство сервера.

Открываем верхнюю крышку, на внутренней стороне которой нанесены схемы расположения устройств, и получаем доступ к серверу изнутри. Логически внутреннее пространство поделено на несколько частей: наиболее горячая область расположения процессоров, модулей памяти и чипсетов, корзина с жёсткими дисками, отсек для блоков питания и отсек для трёх плат расширения.

Сервер HP Proliant DL380 G5 - вид сзади

Сервер HP Proliant DL380 G5 - аккумулятор RAID контроллера

Самая горячая область закрыта кожухом воздуховода, позволяющим лучше распределить воздушный поток там, где он более всего нужен. На этом кожухе имеются каналы для прокладки кабелей систем хранения и два посадочных места под аккумуляторы RAID-контроллеров. Последние, таким образом, находятся всегда в лёгкой доступности, и чтобы поменять умершую «батарейку», вам не придётся извлекать RAID контроллер – весь процесс займёт менее 5 минут. К слову сказать, никель-металгидридные аккумуляторы компании Varta в этом сервере располагаются прямо рядом с процессорами и модулями памяти и не обдуваются воздухом от вентиляторов. Надеемся, они рассчитаны на высокие температуры. Ну а если нет – они очень легко меняются :).

Сервер HP Proliant DL380 G5 - радиаторы процессоров

Сервер HP Proliant DL380 G5 - радиаторы процессоров

Два процессора располагаются в непосредственной близости друг от друга и используют общее крепление радиаторов. Возле процессоров установлены 8 слотов для модулей памяти FBDIMM. За процессорами – пара VRM модулей (Voltage Regulation Module), которые обеспечивают стабилизацию напряжения при повышенных нагрузок. Такое впечатление, будто инженеры HP позаимствовали идею VRM модулей у компании Gigabyte с её платами для оверклокеров. Мало того, что модули имеют массивные радиаторы, мешающие воздушному потоку, так они ещё и создают впечатление какой-то ненадёжной конструкции. Иначе они не были бы заменяемыми.

На плате имеется один внутренний USB порт, очевидно для загрузки системы с флэшки. В кластерных системах, а так же там, где нужно всё пространство дисковой системы (например при использовании сервера в качестве NAS-а), эта возможность будет актуальной.

Сервер HP Proliant DL380 G5 - блок вентиляторов

Поговорим о системе охлаждения. Для эффективного продува воздуха сквозь сервер используются 6 вентиляторов размерами 60x60x40 мм , и ещё по 2 размерами 40x40x20 на каждом из блоков питания. Основные вентиляторы производства Delta Electronics имеют максимальную мощность 21.6 Вт и управляются электроникой. 4 таких системных вентилятора объединены в блок охлаждения процессоров и электроники. Этот блок можно легко снять и заменить на такой же, а можно переставить поближе к процессорам, или даже поставить два таких блока последовательно для лучшего охлаждения. Каждый из вентиляторов имеет функцию лёгкой замены. Выполненные в виде картриджей, — они избавляют от необходимости вручную соединять проводки. Вентиляторы имеют по одной крыльчатке, никаких средств снижения вибрации не предусмотрено.

Сервер HP Proliant DL380 G5 - вентиляторы райзерного отсека

Ещё два вентилятора охлаждают блок жёстких дисков и платы расширения, установленные в отсеке райзера. Этот отсек совмещает в себе плату-райзер на два порта PCI Express 8x и один PCI Express 4x и корпус, придающий жёсткость конструкции и направляющий воздушный поток.

Жаль только, что хорошего потока воздуха через платы в отсеке можно не ожидать – со стороны вентиляторов райзер имеет решётку с довольно-таки редкими секциями, а на протяжении всего отсека для этих плат, в корпусе сервера расположена вентиляционная решётка. Поток будет выходить из корпуса раньше, чем достигнет начала платы расширения. Ещё один недостаток райзера – это сложность установки плат с внутренними кабелями, как например, RAID контроллеры. Дело в том, что с обратной стороны коробки райзера не предусмотрено отверстий для подобных шлейфов и кабелей.

Все элементы внутри сервера доступны без инструментов. Правда, для доступа к платам расширения, установленным в райзер, вам потребуется ключ-звёздочка (можно открутить и руками, но ключом удобнее). Этот ключ вы найдёте на задней панели снаружи сервера.

RAID контроллер HP Smart Array P400

Как уже было сказано, опционально вы можете установить в сервер RAID контроллер HP SmartArray P400 . Эта плата устанавливается в низкопрофильный слот PCI Express 4x и позволяет подключить все 8 жёстких дисков. Контроллер построен на 500 МГц процессоре LSI Logic LSISAS1078 и может быть доукомплектован 512 Мб памяти DDR II 667 MHz. Контроллер имеет аппаратную поддержку RAID 5 и RAID6. В некоторых модификациях контроллер может быть интегрирован на материнскую плату.

Этот контроллер поддерживает до 16 дисков, скорость – до 300 Мб/с (SAS 3Gbps, SATA-1.5 Gbps) на одно физическое соединение, массивы объёмом более 2 Тб, а при подключении всех восьми винчестеров производитель обещает скорость – до 2 Гб/с на массиве. Правда, по современным меркам процессор контроллера, конечно, слабоват. Тем не менее, поддерживаются большинство востребованных функций – RAID Migration, stripe size migration, расширение массива и логических дисков, перепрошивка BIOS-а онлайн. А вот функции Snapshot нету.

2.5-дюймовые винчестеры поставляются уже установленными в лотки. Последние крепятся в корзине с использованием виброгасящих пружинных элементов. Индикация каждого диска яркая, хорошо заметная. Паразитная засветка от соседних винчестеров не прослеживается. Защёлки лотков прочные и удобные – всем бы так.

Два сетевых порта управляются контроллерами BroadCom NexXtreme II BCM5708, подключенными по шине PCI Express 4x. Этот контроллер имеет поддержку Accelerated iSCSI , для реализации которой придётся докупать лицензионный ключ

Ещё одна особенность сервера HP ProLiant DL380 G5 проявляется при включении. Сервер сильно вибрирует, и причина тому – его вентиляторы. Большие и мощные, они не имеют никакой защиты от вибрации, и когда электроника выводит их на повышенную скорость, вибрация очень сильная. На минимальной скорости сервер довольно-таки громко шумит, так что в офисе лучше установить его подальше от рабочего персонала. BIOS материнской платы не позволяет менять профайл для скорости вентиляторов. В нашей конфигурации в режиме простоя сервер потреблял порядка 270 Вт . При тестировании – до 400 Вт .

Сразу скажу, что в рамках данной статьи мы не будем касаться настроек BIOS, а так же функций удалённого мониторинга и конфигурации, так как практически они идентичны для обоих серверов, а информации по ним достаточно на сайте производителя. Лучше мы незамедлительно перейдём ко второму серверу, HP DL380G6.

HP ProLiant DL380 G6

Если сервер DL380 G5 был продуман по своей серверной конструкции, то DL380 G6 – это шедевр . Современные требования по низкому энергопотреблению, высокой доступности сервера, а так же предыдущий опыт заставили разработчиков продумать его до мелочей. Прежде всего, внешне сервер выглядит уже более презентабельно. Серая лицевая панель, напоминающая торпедо «ВАЗа» уступила место чёрной из более качественного пластика. Теперь и надписи лучше видны, да и раскладка лицевой панели стала удобнее.

Сервер HP ProLiant DL380 G6

Жёсткие диски теперь располагаются горизонтально, в два столбика, чуть смещённых влево относительно центра. Опционально вы можете заказать корзину, которая позволит устанавливать в сервер до 16 жестких дисков формата SFF (2.5″). Оптический привод вынесен наверх, а панель индикации сервера вместе с портами и кнопками – влево. Теперь на ней же установлены и светодиоды, показывающие статус работы сети. VGA выход, пара USB портов, кнопка выключателя и индикации UID остались без изменений, и Reset-а до сих пор нет. Зато слева от них появилась бирка с параметрами доступа к системе удалённого мониторинга iLO. К слову, на DL380 G5 такая бирка навешивалась на верёвочке, как ценник на мешке с сахаром.

Сервер HP ProLiant DL380 G6

В отличие от предшественника, HP DL380 G6 может иметь до 4 сетевых портов, плюс один RJ45 порт iLO 2 мониторинга. Аналогично, для подключения KVM сзади доступны два PS/2 порта, два USB 2.0, второй VGA выход и RS-232 порт.

Сервер HP ProLiant DL380 G6

Сервер HP ProLiant DL380 G6

В нашей комплектации сервер имел избыточный блок питания мощностью 750 Вт, состоящий из двух модулей с функцией горячей замены. Для этих блоков питания HP заявляет наличие сертификатов 80Plus Gold и эффективность на уровне 92% . DL380 G6 поддерживает установку до 6 плат расширения с интерфейсом PCI Express, две платы – низкопрофильные, остальные четыре – полнопрофильные. Как и в DL380 G6 , здесь охлаждение осуществляется забором воздуха через лицевую панель и выбросом его через вентиляционные решётки в боковых стенках корпуса. Однако, и задняя стенка корпуса имеет больше вентиляционных отверстий, так что определённо, корпус легче продувается по длине, чем у G5. Но давайте заглянем внутрь сервера.

Сервер HP ProLiant DL380 G6

Да, первое впечатление от конструкции подтверждается и здесь – шасси действительно стали более грамотными. Корпус поперёк поделён на зоны, и он стал более удобным. Однако, есть и свои особенности. Например, корпус с райзерами теперь единый для всех плат расширения, и чтобы получить доступ к чему-то внутри сервера (кроме вентиляторов), вам придётся в первую очередь извлекать райзер со всеми платами расширения. Даже для замены батарейки RAID контроллера. На каждом из райзеров установлен светодиодный индикатор его состояния. Удобно, чтобы быть уверенным, что плата райзера полностью вошла в соответствующий разъём материнки, на неё подаётся питание – и всё в норме. Трудно сказать однозначно – хорошо это, или плохо иметь такой райзер, который надо извлекать первым делом, если вам что-то потребуется в сервере. Скорости обслуживания он явно не добавляет. Однако, райзер в DL380 G6 уже не мешает устанавливать платы, к которым подключаются кабели. А для длинных плат, устанавливаемых в верхние отсеки, имеются фиксаторы с обратной стороны.

Опционально, вы можете приобрести сервер с райзерами, имеющими слоты PCI Express 4x, 8x, и даже 16x, а так же PCI-X 133 MHz. Однако, кабелей для подключения G-GPU карт типа nVidia Tesla 1060 в комплекте нет.

Сервер HP ProLiant DL380 G6 - процессоры и память

Так как архитектура Nehalem требует установки FBDIMM слотов индивидуально для каждого процессора, то естественно, здесь они занимают больше места. Всего доступно 18 слотов памяти , по 9 на каждый процессор. Суммарный объём устанавливаемой памяти – до 192 Гб . Инженеры Hewlett Packard решили установить процессорные гнёзда и слоты для памяти в ряд, таким образом, что они занимают всю ширину материнской платы и пропускают через себя весь воздушный поток сервера.

Сервер HP ProLiant DL380 G6 - кожух и батарейка

Сверху эта часть материнской платы закрывается массивным пластиковым кожухом, который аналогично DL380 G5 , имеет посадочные места для двух аккумуляторов RAID-контроллера, так же «лежащих» над модулями DIMM и не охлаждаемых воздухом. Единственное – теперь их кабель более удобно проложен по кожуху. Но – только один кабель от одной батарейки. Поставите второй аккумулятор для второго RAID контроллера – и кабель питания будете тянуть, как придётся. Для RAID-контроллера HP SmartArray 410i используется тот же аккумулятор Varta, что и для SmartArray 400p.

Сервер HP ProLiant DL380 G6 - батарейка RAID контроллера

По сравнению с материнской платой, использующейся в ProLiant DL380 G5 , здесь она выглядит современной. Никаких вам заменяемых VRM модулей – все элементы питания встроены на материнку, а наиболее горячие расположены между процессорами и вентиляторами. Да и визуально маленьких радиаторов здесь стало намного меньше. Как уже было сказано, процессоры располагаются посередине материнской платы. Крепление радиаторов – аналогично, как у ProLiant DL380 G5. Кабели питания и кабели SAS проложены вдоль боковых стенок корпуса, очень аккуратно, ничего не торчит, а следовательно не мешают охлаждению.

Сервер HP ProLiant DL380 G6 - процессоры и память

Поговорим об охлаждении. В сервере HP ProLiant DL380 G6 используются 6 вентиляторов размерами 60x60x40 мм , плюс – по 2 вентилятора 40x40x20 мм в каждом из блоков питания. Системные вентиляторы имеют функцию лёгкой замены, вместо металлической решётки на них используется более тонкая пластиковая. Каждый из вентиляторов, произведённый компанией Delta Electronics, имеет одну крыльчатку, но он буквально подвешен на резиновых нохках, предотвращающих распространение вибрации. Как результат – корпус не вибрирует от вентиляторов никогда! Даже, когда они заводятся на максимальную скорость – вибрация совершенно отсутствует. Пространство корпуса рассчитано таким образом, чтобы создавать минимальное сопротивление воздуху как на входе, так и на выходе. В итоге, забегая вперёд, скажу, что в обычном режиме сервер работает очень тихо, сопоставимо по громкости с нормальным настольным компьютером! Спасибо компании Hewlett Packard за тихий сервер!

Сервер HP ProLiant DL380 G6 - вентиляторы

Интересно, что в DL380 G6 даже оптический привод вы можете заменить буквально за минуту, без инструментов. Интерфейс Serial ATA позволит легко подобрать новый DVD-RW, если в этом возникнет необходимость. К слову, DL380 G5 так же имеет функцию горячей замены DVD-RW привода .

RAID контроллер HP Smart Array P410i

На серверах HP DL380 G6 установлены интегрированные аппаратные SAS RAID контроллеры HP Smart Array P410i . В зависимости от модификации сервера, они могут не иметь кэш-памяти вовсе, иметь 256 Мб 40-битной памяти DDR2-800 с аккумулятором или без, или 512 Мб 72-битной памяти DDR-800 с аккумулятором. Этот контроллер поддерживает SAS 6 Gbps, SATA 3 Gbps, и он подключен по интерфейсу PCI Express 8x с пропускной способностью шины до 4 Гб/с. Поддержка RAID 5 осуществляется только на моделях, имеющих защищённую «батарейкой» кэш-память объёмом 256 Мб или выше . А вот за поддержку RAID 6 и RAID 6+0 придётся раскошелиться ещё и на Smart Array Advanced Pack License, то есть, лицензионный ключ с техподдержкой 24×7 – ещё около 370$ . Примерно столько стоит полноценный RAID контроллер с поддержкой RAID 6, в котором никаких лицензий не надо.

Материнская плата сервера HP DL380 G6

Материнская плата сервера HP DL380 G6 имеет один внутренний порт USB 2.0 и один слот для SD-карт, с которого можно загружать операционную систему. В качестве сетевых контроллеров используются два двухпортовых BroadCom PCM5709C с интерфейсом PCI Express 4x, имеющих аппаратный акселератор iSCSI , а так же протоколов CIFS и NFS, поддержку балансировки нагрузки и агрегации. Никакая активация или лицензирование для использования этих функций не требуется.

При тестировании сервер показал следующие значения энергопотребления: 230 Вт в режиме простоя и 380 Вт в режиме максимальной нагрузки.

В общем, сервер DL380 G6 действительно подрос на голову по сравнению с G5, и это даже не касается новой архитектуры процессоров Nehalem, а используемых технологий. С одной стороны, приятно, что для реализации акселератора iSCSI теперь не придётся покупать лицензию, с другой стороны – лицензия на RAID 6 всё же нужна. Но достаточно разговоров, перейдём к делу, а именно – тестированию серверов.

Тестирование

Для тестирования использовались серверы следующих конфигураций:

HP ProLiant DL380 G5

HP ProLiant DL380 G6 491316-421

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *