Перейти к содержимому

Ah01797 client denied by server configuration как исправить

  • автор:

client denied by server configuration: ошибка

Сильно упали позиции на одном сайте, вроде ничего не менял начал смотреть все. В эррор логах наткнулся на множество ошибок типа: [Thu Jun 16 10:10:11 2011] [error] [client 85.114.85.194] client denied by server configuration: /var/www/юзер/data/www/сайт.ru/content, referer: http://yandex.ru/yandsearch?text. Погуглил — все пишут что это пробелма в апаче 2,2 и нужно убрать Deny from all в файле httpd.conf У меня там прописано следующее:

Подскажите пожалуйста не опасно ли убирать Deny from all, на что вообще повлияет это действие?
На сайте с 25.04.2008
16 июня 2011, 06:39

Sinaps:
Сильно упали позиции на одном сайте, вроде ничего не менял начал смотреть все. В эррор логах наткнулся на множество ошибок типа:

[Thu Jun 16 10:10:11 2011] [error] [client 85.114.85.194] client denied by server configuration: /var/www/юзер/data/www/сайт.ru/content, referer: http://yandex.ru/yandsearch?text.

Погуглил — все пишут что это пробелма в апаче 2,2 и нужно убрать Deny from all в файле httpd.conf

У меня там прописано следующее:

Подскажите пожалуйста не опасно ли убирать Deny from all, на что вообще повлияет это действие?

повлияет только на в вашем случае не поможет и крайне не рекомендуется. для начала смотрите .htaccess, начиная с последнего уровня вложенности до корня фс далее смотрите httpd.conf на предмет дефолтных значений например в , и т.п.

Ah01797 client denied by server configuration как исправить

Наши партнеры

Сведения об ООО «Ваан» внесены в реестр аккредитованных организаций, осуществляющих деятельность в области информационных технологий. ООО «Ваан» осуществляет деятельность, связанную с использованием информационных технологий, по разработке компьютерного программного обеспечения, предоставлению доступа к программе для ЭВМ и является правообладателем программы для ЭВМ «Платформа FL.ru (версия 2.0)».

Продолжая пользоваться сайтом, вы соглашаетесь с условиями использования файлов cookie

Ошибка AH01630: client denied by server configuration — Apache 2.4

Каждый раз когда разворачиваю новый сервер получается что-то да обновилось, в этот раз Apache 2.4 вытеснил бывший по-умолчанию Apache версии 2.2.

Apache logo http, Апач логотип вебсервер

В версии 2.4 немного изменился файл конфигурации, поэтому так просто скопировав «старые конфиги» и файлы виртуальных хостов этим дело не ограничится.

В Apache 2.4 получаем ошибку AH01630: client denied by server configuration

Решение как обычно простое, но в спешке можно долго его искать, поэтому записываем

Удаляем все «Order deny, allow» и «Order allow, deny» и

меняем «Deny from all» на «Require all denied»
меняем «Allow from all» на «Require all granted»

Пример работающего файла виртуального хоста Apache 2.4:

 ServerName nemcd.com ServerAlias www.nemcd.com ServerAdmin [email protected] DocumentRoot /site/nemcd.com/www Options -Indexes Require all granted Options FollowSymLinks AllowOverride All ErrorLog $/nemcd.com-error.log # CustomLog $/nemcd.com-access.log combined 

В данном случае установлено AllowOverride All, поэтому нужно активировать модуль mod_rewrite, так как очень часто нужно использовать файлы .htaccess, если они не нужны, можно написать AllowOverride None:

Чтобы работали .htaccess выполняем команду

a2enmod rewrite

Перезапускаем апач после внесенных изменений или делаем стоп, старт.

service apache2 reload

Фразы: не стартует Apache 2.4, изменения в .conf файле, ошибка AH01630

Форум русскоязычного сообщества Ubuntu

Страница сгенерирована за 0.044 секунд. Запросов: 23.

  • Сайт
  • Об Ubuntu
  • Скачать Ubuntu
  • Семейство Ubuntu
  • Новости
  • Форум
  • Помощь
  • Правила
  • Документация
  • Пользовательская документация
  • Официальная документация
  • Семейство Ubuntu
  • Материалы для загрузки
  • Совместимость с оборудованием
  • RSS лента
  • Сообщество
  • Наши проекты
  • Местные сообщества
  • Перевод Ubuntu
  • Тестирование
  • RSS лента

© 2012 Ubuntu-ru — Русскоязычное сообщество Ubuntu Linux.
© 2012 Canonical Ltd. Ubuntu и Canonical являются зарегистрированными торговыми знаками Canonical Ltd.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *